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Generisanje histograma obvojnice radio signala 

Emir Hašimbegović 

 
Sadržaj — U ovom radu predloženo je rešenje mernog seta 

za generisanje histograma obvojnice radio signala. Pokazano 
je kako se dobija histogram obvojnice, a koji je osnova za 
statističku procenu funkcije gustine verovatnoće obvojnice i 
za procenu intervala lokalne stacionarnosti slučajno 
promenljive obvojnice radio-signala.   
 

Ključne reči —  histogram, obvojnica, PDF. 
 

I. UVOD 

BVOJNICA prijemenog radio signala fluktuira 
zbog specifičnih uslova prostiranja signala između 

predajne i prijemne antene. U opštem slučaju pomenute 
fluktuacije imaju brzu i sporu komponentu – tj. 
razlikujemo  brzi i spori feding. Sa radiokomunikacione 
tačke gledišta obe fluktuacije bitno utiču na kvalitet 
prenosa u datom radio kanalu. U cilju optimiziranja 
kvaliteta prenosa bitno je poznavati statističke 
karakteristike fedinga. U opštem slučaju feding nije 
stacionaran. Međutim, na relativno kratkom intervalu, 
inače specifičnom za svaki kanal ponaosob, postoji tzv 
lokalna stacionarnost za brzi feding. Poznavanje tog 
intervala bitno je sa teorijske i sa praktične tačke gledišta.  
Generisanjem histograma obvojnice prijemnog radio-
signala stvara se osnova za procenu funkcije gustine 
verovatnoće (u daljem tekstu koristićemo skraćenicu PDF- 
probability density function) obvojnice i za procenu 
intervala lokalne stacionarnosti. Dakle, prvi korak je da se 
formira odgovarajući merni set pomoću koga je moguće 
dobiti pomenuti histogram. U drugom koraku, na osnovu 
statističkog testiranja histograma određuje se PDF 
obvojnice. Ovaj rad odnosi se na formiranje mernog seta 
za generisanje histograma. U komplementarnom radu [1] 
biće dati detalji vezani za statističko testiranje histograma. 

II. BLOK ŠEMA MERNOG SETA 
Osnovni cilj je da dobijemo histogram obvojnice 

prijemnog radio-signala. Dodatni, ali vrlo bitan zahtev je 
da merni set može biti primenjen za različite radio-kanale, 
a koje koriste različite frekvencije.  Imajući u vidu 
navedena ograničenja merni set mora imati strukturu 
down-conversion prijemnika. U tom slučaju deo koji se 
neposredno odnosi na generisanje histogama ostaje 
nepromenljiv bez obzira na radio kanal koji predmet 

analize. Odgovarajuća blok šema mernog seta data je na 
Sl. 1. 
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Sl. 1. Blok šema mernog seta. 
 
Merni set sastoji se od antene A, RF pojačivača, 

lokalnog oscilatora (LO), mešača (M),  filtera (LP0), 
detektora anvelope D, filtera (LP1), A/D konvertora i PC 
računara. Dakle, zaključno sa izlazom iz filtra LP1, 
struktuirali smo down-conversion AM prijemnik. 
Konvertor A/D i odgovarajući softver u PC-u neposredno 
služe za generisanje histograma obvojnice prijemnog 
signala.  
    Imajući u vidu da je mešač širokopojasni sklop, jasno je 
da se za različite radio opsege bira odgovarajući RF 
pojačavač i odgovarajuci LO (ili se jednostavno koristi 
signal generator). Sklopovi posle detektora obvojnice 
moraju imati propusni opseg koji odgovara najvećoj 
očekivanoj frekvenciji slučajne fluktuacije obvojnice, a 
dinamički opseg A/D konvertora mora biti veći od 
očekivanog dinamičkog opsega obvojnice koja se 
analizira.  
   Napred navedene specifičnosti obrazložićemo na 
primeru snimanja histograma obvojnice za signal na 
frekvenciji koja se koristi u WLAN-u. U primeru koji 
sledi osnovna namera je da se pokaže funkcionalnost i 
svrsishodnost mernog seta. 

III. OPIS MERENJA  

A. Opis  mernog mesta 
Opredeljujemo se za in-door ambijent – hodnik  u kome 

su smešteni predajnik (Tx) i merni set (videti tlocrt, sl.2a). 
Funciju predajnika vrši access point WLAN-a. Visine 
predajne i prijemne antene date su na slici 2b. U datom 
ambijentu karakteristične situacije sa stanovišta prostiranja 
radio-signala, pa s tim u vezi i specifične situacije vezano 
za uticaje na obvojnicu signala su: kada je hodnik 
nezaposednut prolaznicima i kada u hodniku postoje 
slučajni prolaznici.  
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Sl. 2. Merno mesto. 

B. Izbor elemenata mernog seta  
Blok Tx (Sl. 2.a. i Sl. 2.b.) koristi WL-5460 firme 

AirLive, tehnički podaci dati su u [2]. Izlazna snaga je 
18dBm. Tx koristi dipol  antenu. Za merni set upotrebljeni 
su sledeći blokovi: Antena dipol  impedanse 50 Ω; blok 
RF je radio pojačivač firme Mitek; lokalni oscilator LO sa 
frekvencijom f0=2.352 GHz. Za generisanje ove 
frekvencije korišten je sintetizator, filter LP0 je pasivni 
filter  i treba da ima širinu propusnog opsega koja je 
nekoliko puta veća od očekivane brzine fedinga koji treba 
analizirati (1MHz); mešač M  realizovan je na bazi sklopa 
ADE 35 čiji su tehnički podaci dati u [3], u bloku D 
koristi se  kolo AD8318 (logaritamski detektor obvojnice) 
sa tehničkim podacima datim u [4]; pasivni filter LP1 ima 
graničnu frekvenciju 25 KHz; u bloku A/D koristi se 
konvertor firme ECON i ima oznaku DT-9812-10V [5]; 
PC računar upotrebljen u ovom merenju mora ispunjavati 
sledeće minimalne hardverske uslove: 
-CPU Dual Core  1.8 GHz, 
-RAM  DDR2 4 Gbit, 800 MHz, 
-HDD 80 Gbit, 
-MB  magistrala 800-1066 MHz. 

Radi  razumevanja funkcionisanja mernog seta bitni su 
sledeci detalji:  

(a) veza između napona Vout(mer)  na izlazu 
logaritamskog detektora i snage Pin(dBm) na ulazu mernog 
seta je: 

dBmdBmVmerVoutdBmPin 6.9)}/0245.0/()({)( −−=  (1) 
Pošto je impedansa antene 50 Ω izraz (1)  možemo 
konvertovati u napon, pa je napon obvojnice, Ua(V), na 
antenskom priključku mernog seta: 

)20/(10*224.0)( Pin
a VU =     (2) 

 (b) 12 bitni  A/D konvertor podržava do 50000 sampl/s 
Konvertor je preko USB porta vezan je na PC računar, i 
poseduje aplikativni softver (QuikDag). 

 

C. Generisanje histograma 
 Nije od suštinskog značaja kako ćemo semplovane 
rezultate obraditi i dobiti histogram. U ovom radu 
predstavljeno je jedno od mogućih softverskih rešenja. 
Softverski alat koji smo za ovu priliku razvili prilagođen 
je konkretnom problemu i opremi koju smo imali na 
raspolaganju. 

Tx Merni 
set 

R=3 m 

D=10 m 
AAt

 Kada aktiviramo program za akviziciju podataka 
(QuikDag)  setovaćemo podatke o broju   semplova 
(Sample Rate) kao i podatak o vremenu trajanja akvizicije 
Sl. 3. (Stop Recording-Time (sec)). 
 

 

Merni 
set 

Tx 

h1= 2,5m 
h2=1,50

D=10m 
At A 

Sl. 3. Setovanje parametara akvizicije podataka. 
 

Kako je naznačeno na Sl. 3. startujemo akviziciju 
podataka (naznačeno zeleno dugme). Posle isticanja 
zadatog vremena, pojaviće se sledeći dijalog na monitoru 
PC računara Sl. 4. 
 

 
Sl. 4. Snimanje fajla akvizicije podataka. 

 
Ovako snimljen fajl u tsv formatu otvorićemo putem 
aplikacije NOTPAD, i izbrisati zaglavlje kako je 
prikazano na  Sl. 5. 
 

 
Sl. 5. Brisanje zaglavlja tsv fajla. 
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A zatim izvršiti konverziju fajla kako prikazuje  Sl. 6. 
 

 
Sl. 6.Konverzija fajla u txt  format. 

 
 Ovako dobijeni fajl signal01.txt snimljenih akvizicijonih 
podataka je spreman za dalju obradu podataka. Za izradu 
softvera koristićemo MS Access 2003, koja je sastavni deo 
Microsoft office paketa. Programiranje u Accessu izvest- 
ćemo u vizual dizajn modu. Tok realizacije ovog softvera 
daćemo dijagramima  toka na Sl. 7. i Sl. 8. 
 

  
Sl. 7.Dijagram dizajna Tabele Akvizicija. 

 
 U polju Vout tabele Akvizicija snimićemo  akvizicione 
podatke koje ćemo obrađivati, polje C je takozvani brojač 
akvizicionih podataka.  
    Za dalju obradu podataka i dobijanje određenih 
rezultata potrebno je dizajnirati tzv upite (Queries), koji će 
obraditi akvizicione podatke i dati određene upotrebljive 
rezultate. Kada dođemo do poslednjeg koraka na Sl. 7. bez 
ikakvog prekida se nastavlja dizajniranje upita prema 
dijagramu na Sl. 8. 
 Upit1 Preračunava akvizicione podatke iz polja Vout po 
jednačini (1) i (2) na antenskom priključku mernog seta i 
definiše interval posmatranja (t,t1) akvizicionih podataka 
iz tabele Akvizicija. Vrednosti t, t1 se zadaju u sekundama.  
 Upit2 Za svoje ulazne podatke koristi Upit1 i pronalazi 
srednju vrednost Uasr, varijansu Varu koristeći već 
definisane funkcije u MS Accessu (Avg-srednja vrednost i 
Var-varijansa). Ovim upitom određujemo interval 
stacionarnosti. 
 Upit3 Za svoje ulazne podatke koristi Upit1. Grupiše 
podatke  Ua i  izračunava  broj  podataka  (Ua) N, u okviru 

jedne grupe podataka. Ovi podaci služe za  generisanje 
histograma. 

 
Sl. 8. Dijagram toka dizajniranja upita. 

Dizajn upita Upit1 
Upit 1 koristi kao ulazne podatke tabelu Akvizicija 

Aktivirati : Queries>Design>Query>Sow Table>Akvizicija 
U prvom polju Field upisati  Vout 
U drugom polju Field upisati C 
U polju Criterija upisujemo: >t*50000 and <t1*50000 or = 
t1*50000. 
Ovim smo definisali vremenski interval (t,t1) posmatranja 
Uprvim sledećim praznim poljima Field upisati :  
Pin:((Vout/(-0,0224))-9,6 
Ua:0,0244*10^(Pin/20) 
Snimanje dizajniranog upita; 
File>Save> Quiry name : Upit1 

Dizajn upita Upit2 
Upit 2 koristi kao ulazne podatke upita Upit1 

Aktivirati : Queries>Design>Query>Sow Table>Qery>Upit1 
U prvom polju Field upisati:Uasr:Ua 
Aktivirati Vew>Totals>Avg 
U drugom polju Field upisati:Varu:Ua 
Aktivirati Vew>Totals>Var 
Snimanje dizajniranog upita; 
File>Save> Quiry name : Upit2 

Dizajn upita Upit3 
Upit 3 koristi kao ulazne podatke upita Upit1 

Aktivirati: Queries>Design>Query>Sow Table>Qery>Upit1 
U prvom polju Field upisati:Ua 

Aktivirati Vew>Totals>Group By 
U drugom polju Field upisati: N:C 

Aktivirati Vew>Totals>Count 
Snimanje dizajniranog upita; 

File>Save> Quiry name > Upit3 

Dizajn Tabele: Akvizicija 
Aktivirati :Table - Design 

Definisanje polja u dizajn modu tabele: 
  1.Vout            Data typ Number>Double 
  2.C                  Data typ Autonumber>Integer 

Snimanje dizajnirane tabele 
 Fajl-Save > Table Name>Akvizicija. 

Pokretanje programa MS Access 2003 
Otvaranje novog  fajla Akvizicija.mdb 
File>New>File name : Akvizicija - create 

 
 Kada smo završili izradu programa Akvizicija.mdb 
potrebno je akvizicione podatke koji se nalaze u fajlu 
signal01.txt preslikati u program Akvizicija.mdb. 
Postupak je prestavljen dijagramom na Sl. 9. 
 

RUN NOTPAD.exe 
File>Open>Signal01.txt 
Edit>Select all 
Edit>Copy 

RUN Akvizicija.mdb 
Table>Akvizicija>Open>Select Ua 

Edit  > Paste 

Sl. 9. Preslikavanje podataka u Akviziciju.mdb. 
 

 Sa programom Akvizicija.mdb dobili smo softverski 
alat skojim možemo obraditi experimentalne podatake. Da 
bi generisali histogram obvojnice potrebno je odrediti 
interval stacionarnosti, jer samo u tom intervalu histogram 
ima statističku validnost. Interval stacionarnosti tražimo 
tako što izvršimo redosled naredbi naznačen na dijagramu 
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toka Sl.10. Pri svakom pokretanju Upita2 javi se pitanje 
koja je vrednost za t, a zatim za t1. Upisujemo vrednost za 
t i t1. Po predpostavci polazimo od intervala t=0 s, t1=1 s. 
Upit2 daje rezultate varijanse (Varu) koje ćemo zabeležiti. 
Zatim širimo interval na t=0 s, t1=2 s. Opet ponavljamo 
postupak i beležimo varijansu Varu. Tako nastavimo sve 
dok varijansa ne počne da menja vrednost. Kada dođemo 
do intervala gde se  vrednost varijanse Varu menja, znači 
da smo pronašli interval stacionarnosti (t=0 s, t1s). 

 
 

Sl.10.Dijagram toka testiranja intervala stacionarnosti. 
 

Kada smo odredili interval stacionarnosti, tada 
aktiviramo Upit3, Sl.11. i generišemo histogram koristeći 
MS EXCEL softver kako je dato prema dijagramu toka na 
Sl.11. 
 

 
Sl.11.Generisanje Histograma u Excel tabeli. 

 
Prema opisanom mernom mestu Sl. 2. uradili smo 

testno snimanje u jednoj ustanovi i to u dva slučaja: u 
praznom hodniku i zaposednutom hodniku (4 osobe). 
Radio spektar u ovom hodniku je monitorisan, nisu 
zabeleženi signali na posmatranoj frekvenciji (2.4 GHz).  

 
Sl.12. Histogram obvojnice praznog  hodnika. 

 
Snimanje akvizicionih podataka je trajalo po 30 minuta 

(1800 s, sempling-rate  50000 sempl/s). Rezultati 

obrađenih podataka su dati na Sl.12. i Sl.13. 
Pri čemu se u praznom hodniku stacionarnost pokazala 

na celom intervalu snimanja, a varijansa Varu=0.076, dok u 
primeru na Sl.13. interval stacionarnosti je 44 s, a 
varijansa Varu=0.061. 

 

RUN Autoexec.mdb 
Queries>Upit2 Open 
t  :0 
t1:1,2... 

Upit2 prikazuje rezultate 
Varu , Uasr.

Sl.13. Histogram obvojnice zaposednutog hodnik. 

IV. ZAKLJUČAK 
U radu elaboriran i na primeru WLAN kanala 

verifikovan merni set za generisanje histograma obvojnice 
fluktuirajućeg prijemnog radio signala. Međutim, merni 
set može da posluži (direktno ili uz male prepravke) i za 
druge radio primene gde se zahteva generisanje 
histograma radi kasnije analize odgovarajućih statističkih 
karakteristika. Tipičan takav primer moguće primene 
odnosi se na histogram faze na izlazu fazne petlje. 

Open>Upit3 
Select all record 
Edit Copy 

RUN Excel.XLS 
File > New Paste 
Edit > Select all > N 
Insert> Picture>Chart 
Odaberemo oblik histograma : 
Series>Rows>Finish 
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ABSTRACT 
This paper contains a suggestion of measurement set 

solution for generation of radio signal envelope. It shows 
how to get envelope histogram, that is basically  for 
statistic estimate probability density function and how to 
estimate interval local stationary  random variables radio 
signal envelope. 

GENERATING HISTOGRAM OF RADIO 
SIGNAL ENVELOPE 

Emir Hašimbegović 
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